Welcome to Project Dalek

You need to be a member in order to access our content.

 

Click Here To Join!

 

For instant access to the plans and all Forum features, choose Active Membership.

John

Forum Upgrade

57 posts in this topic

I'm currently in the process of preparing for a major Forum upgrade. This will happen some time over seven days and will cause the Forum to be unavailable for a short time.

Once the upgrade is completed there will still be a lot of additional work for me to do, to get the place looking and functioning in the way that you are all used to. Some features, (such as the Gallery, Downloads/Maps etc) may not be available straight away.

Also, the Forum will, initially, revert to a very basic blue look and feel.

Please don't panic if you see this. It will only be a temporary measure, after the upgrade but before the updated Project Dalek theme is applied.

I will be posting a couple of topics after the upgrade to explain how it impacts on posting and how the Forum Guidelines will change to accommodate this.

There will also be the opportunity for you to ask any technical question you may have, once the revised board is up and running.

I'm hoping that this major upgrade goes without a glitch but there is always the possibility that the Forum may be down (with SQL error messages) in the first few hours post-upgrade. Should that happen, your patience is greatly appreciated.

0

Share this post


Link to post
Share on other sites

Good luck with the upgrade John,

As always your hard work is much appreciated.

Russell

0

Share this post


Link to post
Share on other sites

I've done a lot of beta testing but there is no guarantee that it will all go to plan. I'm hoping there are no major issues, so I can get the place looking and functioning as normal quickly and without too much downtime.

0

Share this post


Link to post
Share on other sites

Best of luck John. I feel your angst. I am just about to hot add a new fibre module to a live core switch... all should be ok, but then again I could take out the whole network... ;)

Appreciate your efforts.

0

Share this post


Link to post
Share on other sites

OK, so the upgrade seems to have gone reasonably well. There are still a lot of background tasks running, so some oddness and slowness is to be expected over the next few hours. Things like image attachments may take a while to show. They all have to be rebuilt.

There is also a lot more work for me to do, to get the menus and extra features working. Please bear with me and refrain from flagging up any issues until I let you know that the upgrade is complete... at which point I can start looking at any problems you may have encountered.

Meanwhile, this topic explains a bit about how posting photos will change.

0

Share this post


Link to post
Share on other sites

These are the major issues that we are currently aware of and working to fix:

 

  1. The Gallery images are missing. This is an issue with the paths to the correct storage directories, which have changed.
     
  2. The Downloads area has missing images and all files are currently broken. As above, a paths issue.
     
  3. Thumbnails in existing posts are missing.
     
  4. The member map has lost member markers. These will have to be added back in, over time, by the members.

Your patience is much appreciated, while these issues are addressed. :) 

0

Share this post


Link to post
Share on other sites

Two major issues fixed (struck through, above) and a potential fix found for the attachment thumbnails... though this would be very labour intensive, so I'm holding out for something better.

 

It has been pointed out to me that message attachments have also vanished. I don't think there's much I can do about that, I'm afraid. It would be difficult to deal with because of the private nature of the files. It's something we're going to have to live with, I'm afraid.

 

Work continues...

 

 

0

Share this post


Link to post
Share on other sites

The main front page index has now had the subforums removed, making it look more like it originally did. This will reduce the amount of scrolling that is needed to navigate through the sections.

 

Attachment thumbnails issue is still ongoing.

 

Note that new photos will show in posts. When posting, please take the time to add the photos into the post using the little plus symbol in the corner of each one. Put them in side by side. Leaving them at the bottom, without placing them, will cause them to display in a long column, which isn't particularly nice to view. 

0

Share this post


Link to post
Share on other sites

More progress...

 

  1. Pre-upgrade attachments now showing, but at full size. Work continues to make them display as thumbnails instead. (see my note above for how you should embed images, to make them arrange correctly).
  2. Dalek Map made responsive for handheld devices.
  3. Various tweaks to the front page and the information it provides.
0

Share this post


Link to post
Share on other sites

There may be some performance issues over the next 48 hours while the thumbnails (in posts) are rebuilt. Apologies if the Forum is slow to respond during this time.

0

Share this post


Link to post
Share on other sites

Work ongoing, with rebuilding image thumbnails to the correct size. Some early (2005) posts now have the correct thumbnails.

 

At some point in the near future, all images may break again. Don't panic if you see this, it's just a consequence of migrating the images to new hosting. This may take a few days but all images should eventually recover.

 

I'm almost at the point where I can start answering any questions you may have about the new features... just not quite. I'll open a new topic for support questions as soon as I can.

0

Share this post


Link to post
Share on other sites

Gallery images will become broken for a short time, during an essential maintenance task. Apologies for the inconvenience.

0

Share this post


Link to post
Share on other sites

Gallery maintenance now complete.

 

I have a workaround for the post thumbnail issue that I will be implementing over the next few days. This will force images to display as thumbnails. However, please note that image sizes may change from time to time as I need to modify this fix in order to work on getting this problem fixed properly. I anticipate this to be several months work. :(

 

And the good news is: All markers are now back on the Member Map, (after some nail biting, database hacking).

0

Share this post


Link to post
Share on other sites

All major Forum issues are now resolved. If you find something that isn't working properly then please post here and I will investigate.

 

If you have any questions about the changes in functionality (ie you can't figure  out how a feature works) then post a topic in the 'Technical Questions' section and I'll do my best to help. :)

0

Share this post


Link to post
Share on other sites

Some file downloads posted before 2011 were coming up as broken. This has now been fixed.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now